Installation

From Mobius Wiki
Jump to: navigation, search

This page will give you the detailed install instructions for Möbius. Select the appropriate version of Möbius and your operating system from the table of contents.

Möbius 2.5

Supported Operating Systems

Due to limited resources, the Möbius team only officially supports the following operating systems and versions. Please note that official support only extends to 64-bit versions of these operating systems. However, Möbius will likely run on many more operating systems and configurations. Please see the Unsupported Operating Systems section for community provided install instructions.

Mac OS X 10.10 Yosemite and above

  1. Install the latest Oracle Java JDK 8.
  2. Install gcc:
    1. Open a terminal and enter this command:
      $ gcc --version
    2. If you see a simple output stating the version, then you already have gcc installed and you can move on.
    3. If a dialog window appears and explains that gcc requires the command line developer tools, click the Install button.
  3. Download the Mobius 2.5 package (DMG) (MD5), double click the DMG file, and drag the Möbius application to the Applications folder.
    • Mobius 2.5 package for Yosemite
    • Mobius 2.5 package for Sierra
    • Mobius 2.5 package for High Sierra
    • If you get an error message saying that Möbius can't be opened because it is from an unidentified developer, do the following (you will only need to do this once):
      1. Open Finder.
      2. Go to your Applications folder.
      3. Right click the Möbius application and select Open.
      4. Click the Open button on the next pop up message.
    • The first time you run Möbius, you may be prompted to install a Java runtime. Confirm that you would like OSX to find and install the runtime.

Mac OS X 10.9 Mavericks

  1. Install the latest Oracle Java JDK 8.
  2. Install gcc:
    1. Open a terminal and enter this command:
      $ gcc --version
    2. If you see a simple output stating the version, then you already have gcc installed and you can move on.
    3. If a dialog window appears and explains that gcc requires the command line developer tools, click the Install button.
  3. Download the Mobius 2.5 package (DMG) (MD5), double click the DMG file, and drag the Möbius application to the Applications folder.
    • If you get an error message saying that Möbius can't be opened because it is from an unidentified developer, do the following (you will only need to do this once):
      1. Open Finder.
      2. Go to your Applications folder.
      3. Right click the Möbius application and select Open.
      4. Click the Open button on the next pop up message.
    • The first time you run Möbius, you may be prompted to install a Java runtime. Confirm that you would like OSX to find and install the runtime.

Mac OS X 10.8 Mountain Lion

  1. Install the latest Oracle Java JDK 8.
  2. Install gcc:
    1. Install the latest version of XCode from the Mac App Store.
    2. Open XCode once installed.
    3. Click on the XCode application menu and select Preferences...
    4. Click on the Downloads tab.
    5. Find the item in the Components list called Command-Line Tools and click the Install button to the right of it.
    6. Once done, close XCode completely.
  3. Download the Mobius 2.5 package (DMG) (MD5), double click the DMG file, and drag the Möbius application to the Applications folder.
    • If you get an error message saying that Möbius can't be opened because it is from an unidentified developer, do the following (you will only need to do this once):
      1. Open Finder.
      2. Go to your Applications folder.
      3. Right click the Möbius application and select Open.
      4. Click the Open button on the next pop up message.
    • The first time you run Möbius, you may be prompted to install a Java runtime. Confirm that you would like OSX to find and install the runtime.

Ubuntu 16.04 Xenial Xerus

  1. Download the Möbius 2.5 package (DEB) (MD5).
  2. Double click the package to install with your default package manager. Accept any dependencies it would like to install.

Ubuntu 14.04 Trusty Tahr

  1. Download the Möbius 2.5 package (DEB) (MD5).
  2. Double click the package to install with your default package manager. Accept any dependencies it would like to install.

Ubuntu 13.10 Saucy Salamander

  1. Download the Möbius 2.5 package (DEB) (MD5).
  2. Double click the package to install with your default package manager. Accept any dependencies it would like to install.

Windows 10

  1. Install the latest Oracle Java JDK 8.
  2. Download the Mobius 2.5 package (EXE) (MD5) and run the installer.

Windows 8

  1. Install the latest Oracle Java JDK 8.
  2. Download the Mobius 2.5 package (EXE) (MD5) and run the installer.

Windows 7

  1. Install the latest Oracle Java JDK 8.
  2. Download the Mobius 2.5 package (EXE) (MD5) and run the installer.

Unsupported Operating Systems

Möbius is only officially supported on the operating systems above. However, it is very likely that you can get Möbius to work on different operating systems with a slight amount of adaptation. Please see the community supplied installation instructions below.

If you don't see your operating system below and decide to try and get it to work, please feel free to email the Möbius development team and we will provide as much support as we can. If you do succeed, please consider writing instructions up on our wiki!

CentOS 6.8 x64

To install Mobius 2.5 on CentOS 6.8, complete the following steps.

  1. Download this tarball.
  2. Extract the tarball and place the mobius-2.5 directory somewhere convenient.
  3. Open a terminal and as root execute the install-prerequisites.sh script contained in the mobius-2.5 directory. This will install some necessary prerequisite packages.
  4. Launch Mobius by running the file called Mobius.
  5. Once Mobius has launched, go to Project->Preferences.
    1. Select the External Tools section.
    2. Add -ldl to the Linker Options field.
    3. Click OK

CentOS 7.3

To install Mobius 2.5 on CentOS 7.3, complete the following steps.

  1. Download this tarball.
  2. Extract the tarball and place the mobius-2.5 directory somewhere convenient.
  3. Open a terminal and as root execute the install-prerequisites.sh script contained in the mobius-2.5 directory. This will install some necessary prerequisite packages.
  4. Launch Mobius by running the file called Mobius.

OpenSUSE 13.2

To install Mobius 2.5 on OpenSUSE 13.2, complete the following steps.

  1. Download this tarball.
  2. Extract the tarball and place the mobius-2.5 directory somewhere convenient.
  3. Open a terminal and as root execute the install-prerequisites.sh script contained in the mobius-2.5 directory. This will install some necessary prerequisite packages.
  4. Launch Mobius by running the file called Mobius.

OpenSUSE 42.3

To install Mobius 2.5 on OpenSUSE 42.3, complete the following steps.

  1. Download this tarball.
  2. Extract the tarball and place the mobius-2.5 directory somewhere convenient.
  3. Open a terminal and as root execute the install-prerequisites.sh script contained in the mobius-2.5 directory. This will install some necessary prerequisite packages.
  4. Launch Mobius by running the file called Mobius.

Previous Versions of Möbius